Minor delivery delays
Incident Report for Trellix
Resolved
The issue was identified and fixed. Email is delivering as expected now.
Posted Oct 03, 2023 - 19:54 UTC
Update
We are continuing to investigate this issue.
Posted Oct 03, 2023 - 18:35 UTC
Investigating
Currently we are monitoring some minor slowness in delivery for our ETP EMEA datacenter. We are still investigating and will update when we learn more.
Posted Oct 03, 2023 - 18:07 UTC
This incident affected: Email Threat Prevention Cloud - EMEA Data Center (Email Delivery).